Legacy Mail Login Issue
Incident Updates
-
Resolved 1 month ago · Aug 13, 2026 11:44 AEST
After a period of monitoring, our technicians have confirmed that the issue has been resolved and things are stable. We want to thank our clients for the patience they've had whilst our team was working on this resolution and apologise for any of the inconveniences caused. If you have further issues please don't hesitate to reach out to us.
-
Recovering 1 month ago · Aug 13, 2026 10:44 AEST
Our Technicians have implemented a fix and are seeing functionality of the Legacy OX Mail system return to normal. We understand how important these services are and appreciate your patience during this time. We will continue to monitor to ensure this is fully resolved.
-
Identified 1 month ago · Aug 13, 2026 09:13 AEST
We are aware of a few customers having issues logging into their Legacy OX Mail Service. Our infrastructure team are working on this as a priority to resolve this matter. If you need any assistance with your account, please contact our team as soon as possible.