Phone System Service Disruption
Incident Report for Webcentral Service Status
Resolved
This incident has been resolved.
Posted Sep 22, 2023 - 18:38 AEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 22, 2023 - 18:28 AEST
Investigating
We are currently experiencing issues with our phone system. Our technicians are investigating this as a priority.

Live chat and email support are unaffected by this issue. Please utilise our live chat for any urgent support, or create a support ticket and our team will respond as soon as possible. During this incident live chat wait times may be longer than usual.

We apologise for any inconvenience caused.
Posted Sep 22, 2023 - 18:05 AEST
This incident affected: Support Center (Phone Sales/Support Line).