Webcentral Website Issue
Incident Report for Webcentral Service Status
Resolved
Our technicians have confirmed that our Webcentral Website is now back online!

Thank you for your patience and we apologise for any inconvenience this has caused.
Posted Feb 16, 2022 - 10:31 AEDT
Investigating
We are currently experiencing issues with the Webcentral Website. Visitors are currently not able to access the website, complete new purchases or access their account console via the website.

Our technicians are working to resolve this interruption as fast as possible.
Posted Feb 16, 2022 - 09:57 AEDT
This incident affected: Network Infrastructure (Internal Network).